Upgrade Preflight Check, comprobar la compatibilidad con WordPress 2.3

Tweet about this on TwitterShare on Google+Share on FacebookEmail this to someonePrint this page

Si estás pensando actualizar tu blog a WordPress 2.3 pero tienes miedo a que algunas de las extensiones (plugins) que más usas dejen de funcionar… Upgrade Preflight Check te puede echar una mano para ayudarte saber si tendrás problemas o no.

El funcionamiento de Upgrade Preflight Check es bastante sencillo pero a la vez muy efectivo, y para explicarlo os voy a pegar aquí parte de la traducción al español de Upgrade Preflight Check que he realizado:

Esta extensión escanea las extensiones y temas en busca de texto que indique problemas de compatibilidad con WordPress 2.3. Cada una de la condiciones viene de conversaciones en la lista de wp-testers y varias entradas en blogs durante los días previos a la publicación de WorddPress 2.3. Aquí están los detalles de lo que se está buscando:

1. Posiblemente incompatible: antigua tabla de categorías — Las antiguas tablas de categorías han sido eliminadas en favor de las nuevas tablas de términos usadas por la nueva característica de etiquetas. Se realiza una búsqueda de “$wpdb->post2cat“, “$wpdb->categories“, y “$wpdb->link2cat” como un indicador de que se usan las antiguas tablas. Más detalles y ayuda. Un archivo que haga referencia a las antiguas tablas de categorías pero también haga referencia a la nueva tabla de términos, no se marca como posiblemente incompatible. Por ejemplo, WordPress Database Backup hace referencia a ambas porque proporciona compatibilidad con anteriores versiones de WordPress junto con la versión 2.3 (para esto hace falta la última versión de WDB, la 2.1.3).

2. Posiblemente incompatible: upgrade-functions.php — Se ha encontrado una referencia a “wp-admin/upgrade-functions.php“, que en WordPress 2.3 ha sido movido y renombrado a “wp-admin/include/upgrade.php“. Es posible que se esté realizando una comprobación para ser compatible con versiones de WordPress anteriores y actuales. Si un archivo también hace referencia a “include/upgrade.php“, asumimos que está comprobando su propia compatibilidad y no lo marcamos como posiblemente incompatible. Más detalles.

3. Cuidado: función get_the_title — Se ha encontrado una referencia a la función “get_the_title“, que ha cambiado la forma en la que devuelve los datos. Puede que en este caso no represente un problema, pero asegúrate. Más detalles.

4. Cuidado: función de enlace permanente obsoleta — Se ha encontrado una referencia a la función “permalink_link()” o “permalink_single_rss()“. Estas funciones se han quedado obsoletas en WordPress 2.3, lo que significa que algún día desaparecerán. Es una buena idea arreglarlas incluso aunque actualmente no representen un problema. Deberían sustituirse con “the_permalink()” y “the_permalink_rss()“. Más detalles.

No obstante, tal como se indica en la propia extensión, tener o no tener problemas enumerados en el informe de Upgrade Preflight Check no es una garantía de compatibilidad o incompatibilidad. Está diseñado como un punto de partida para ayudarte a localizar problemas potenciales.

–Descarga eliminada–

Si lo prefieres, puedes descargar la versión original en inglés de Upgrade Preflight Check en su web.

3 pensamientos en “Upgrade Preflight Check, comprobar la compatibilidad con WordPress 2.3

  1. Pingback: Otra actualización más a LKernelPanic | Share the information

  2. Pingback: Smiths R Us » Archive » Upgrade Preflight Check Spanish Translation

  3. Pingback: Already Taken - Tutoriales, Wordpress themes, Wordpress plugins, Layouts y mucho mas... » WordPress 2.3

Deja un comentario

Tu dirección de email no será publicada. Campos obligatorios marcados con *