WordPress 4.0.1 ya está en el horno…

Tweet about this on TwitterShare on Google+Share on FacebookEmail this to someonePrint this page

Apenas dos semanas después de que se publicara WordPress 4.0, ya podemos ver 28 tickets asignados a una futura versión 4.0.1 que no tardará mucho en aparecer, previsiblemente a primeros de la semana que viene. Ya que entre estos tickets hay uno relativo a la seguridad, que aunque no está marcado como de alta prioridad y se considera que afecta a poquísimos sitios web, nunca se sabe…

También hay dos tickets marcados como alta prioridad, uno de ellos que quizá afecte a más instalaciones de WordPress (yo he visto ya varios casos). Aunque también es cierto que para que el fallo ocurra se deben dar varias circunstancias.

El problema consiste concretamente en un fallo en la función wptexturize() por el cual si tenemos WordPress 4.0 instalado en un servidor con PHP 5.4.8 (otras versiones 5.4.x puede que no se cuelguen pero sí generar carga extra), PHP se “colgará” si hay algún carácter [ en el contenido de una entrada (o cualquier otro tipo de post). Dando como resultado páginas en blanco sin motivo aparente ni mensajes de error.

Teniendo en cuenta que el carácter [ es el que se usa para iniciar los shortcodes, puede ser un problema importante para algunos usuarios que cumplan estos requisitos.

Por este tipo de cosas es por las que siempre recomiendo esperar un tiempo prudencial antes de actualizar cuando no se trata de una actualización de seguridad, y sobre todo si se trata de una versión “mayor” y no una simple actualización menor dentro de la misma rama. Darle al botón de actualizar es muy fácil, pero hay que saber cuándo hacerlo y si estamos en disposición de afrontar los posibles problemas que pueda conllevar.

Por supuesto si estás usando actualmente WordPress 4.0, cuando salga WordPress 4.0.1 actualiza de inmediato (o deja que WordPress lo haga por ti si tienes las actualizaciones automáticas en funcionamiento).

Deja un comentario

Tu dirección de email no será publicada. Campos obligatorios marcados con *